Application slowness

Incident Report for DaySmartvet

Resolved

This incident has been resolved.
Posted Feb 21, 2020 - 09:34 PST

Update

We are continuing to investigate this issue.
Posted Feb 21, 2020 - 09:13 PST

Investigating

We are currently investigating some reports of slowness. We will update shortly.
Posted Feb 21, 2020 - 08:40 PST
This incident affected: VetterSoftware.com.