Client/ Patient Profile Issue
Incident Report for DaySmartvet
Resolved
This incident has been resolved.
Posted Dec 04, 2024 - 05:40 PST
Identified
We are currently experiencing some issues with Patient and client profiles. Our team is aware and we are working to identify and resolve this ASAP. We appreciate your patience and will update the banner once the issue is resolved.
Posted Dec 04, 2024 - 05:30 PST
This incident affected: VetterSoftware.com.